Problema scripts de gatillo

Avisos

Like Tree4Gracias
Tema cerrado
 
Herramientas Desplegado
  #21  
13/09/2016
Predeterminado Respuesta: Problema scripts de gatillo
ok
  #22  
13/09/2016
Predeterminado Respuesta: Problema scripts de gatillo
lo siento, hare un nuevo tema y explicare mi problema
  #23  
13/09/2016
Predeterminado Re: Respuesta: Problema scripts de gatillo
Dicho por kakarotto Ver mensaje
probado en FIRERED
'---------------
#org 0x800000
checkflag 0x4050
if 0x1 goto 0x8800069
lock
faceplayer
msgbox 0x8800035 0x6 '"???: ¡ Ayuda, socorro !"
applymovement 0x2 0x880006C
waitmovement 0x2
msgbox 0x880004F 0x6 '"???: ¡ Ayudame cabron !"
applymovement 0x2 0x8800077
waitmovement 0x2
setflag 0x4050
release
end

'---------------
#org 0x800069
release
end


'---------
' Strings
'---------
#org 0x800035
= ???: ¡ Ayuda, socorro !

#org 0x80004F
= ???: ¡ Ayudame cabron !


'-----------
' Movements
'-----------
#org 0x80006C
#raw 0x8 'Step Down (Very Slow)
#raw 0x8 'Step Down (Very Slow)
#raw 0x8 'Step Down (Very Slow)
#raw 0x8 'Step Down (Very Slow)
#raw 0x8 'Step Down (Very Slow)
#raw 0x8 'Step Down (Very Slow)
#raw 0x8 'Step Down (Very Slow)
#raw 0x8 'Step Down (Very Slow)
#raw 0x56 'Jump in Place (Facing Down/Up)
#raw 0xFE 'End of Movements

#org 0x800077
#raw 0x63 'Question Mark (?)
#raw 0x63 'Question Mark (?)
#raw 0x63 'Question Mark (?)
#raw 0x63 'Question Mark (?)
#raw 0x63 'Question Mark (?)
#raw 0x63 'Question Mark (?)
#raw 0x63 'Question Mark (?)
#raw 0x63 'Question Mark (?)
#raw 0xFE 'End of Movements

Advanced map: Variable:4050 Valor Variable:0000

Si lo haces con var: setvar 4050 0x1
Checkflag 4050?


Yo creo que el problema es bien sencillo ahora que me doy cuenta.
Si os fijáis en primer #org es #org 0x21B70A. Sí 21B70A, un valor offset muy bajo como para haber utilizado un #dynamic 0x700000. Conclusión, has hecho el script sobre un #org antiguo y lo has re-compilado y por eso te da error. Vuelve a poner arriba #dynamic 0x700000 y a todos los #orgs ponle una dirección con un @. Debería funcionar. y por cierto para que no se repita le script al finla pon un "setvar 0x4050 0x1". Y como condición "compare 0x4050 0x1
if 0x1 goto @terminar"

pd: Este problema es tan épico que hasta que no lo soluciones mi vida no tiene sentido
  #24  
13/09/2016
Corazón Respuesta: Problema scripts de gatillo
Dicho por kakarotto Ver mensaje
Pruebalo tal cual y di que tal
Ese script tambien se salta los Applymovements en Sapphire.
  #25  
13/09/2016
Predeterminado Respuesta: Problema scripts de gatillo
Dicho por kakarotto Ver mensaje
Pruebalo tal cual y di que tal
ahora directamente ni se ejecuta
Gracias: Xabier2012
  #26  
13/09/2016
Corazón Respuesta: Re: Respuesta: Problema scripts de gatillo
Dicho por Fan_De_PeteElMagnifico Ver mensaje
Checkflag 4050?


Yo creo que el problema es bien sencillo ahora que me doy cuenta.
Si os fijáis en primer #org es #org 0x21B70A. Sí 21B70A, un valor offset muy bajo como para haber utilizado un #dynamic 0x700000. Conclusión, has hecho el script sobre un #org antiguo y lo has re-compilado y por eso te da error. Vuelve a poner arriba #dynamic 0x700000 y a todos los #orgs ponle una dirección con un @. Debería funcionar. y por cierto para que no se repita le script al finla pon un "setvar 0x4050 0x1". Y como condición "compare 0x4050 0x1
if 0x1 goto @terminar"

pd: Este problema es tan épico que hasta que no lo soluciones mi vida no tiene sentido
Pues en mi caso yo tengo el script puesto en 800000 y nada.
IVPaste: Generador de Paste - VER Paste
  #27  
13/09/2016
Predeterminado Respuesta: Problema scripts de gatillo
Pues no sé, yo directamente lo he copiado de firered a ruby y me va de lujo. Puedes probar este script en algun mapa que no lo hayas cambiado fernando?
  #28  
13/09/2016
Predeterminado Re: Respuesta: Re: Respuesta: Problema scripts de gatillo
Dicho por Lunos Ver mensaje
Pues en mi caso yo tengo el script puesto en 800000 y nada.
IVPaste: Generador de Paste - VER Paste
Hazlo con un compare la condición. Y aunque en teoría no sea necesario, pon unos waitmsg
  #29  
13/09/2016
Predeterminado Respuesta: Problema scripts de gatillo
Encontré el problema. El Person a mover con los Applymovement está demasiado lejos del area de reconocimiento del jugador, por lo que el juego se salta los applymovement y ni siquiera reconoce que el NPC está en donde está.

Lo puse a 4 pasos del jugador y el script funcionó perfectisimamente.
Quien resolvió el problema fue Squeetz, un usuario de PokeCommunity.
  #30  
13/09/2016
Predeterminado Respuesta: Problema scripts de gatillo
ok grax pero yo lo necesito ha esa distancia :/
Tema cerrado

Herramientas
Desplegado

Permisos para publicar mensajes
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los BB code están Activado
Los Emoticones están Activado
El código [IMG] está Activado
El Código HTML está Desactivado
Trackbacks are Activado
Pingbacks are Activado
Refbacks are Desactivado



Extra
Estilo clásico
La franja horaria es GMT +1. Ahora son las 16:20.
Skin Afternoon por Sage